Skip navigation

WordPress 2.7 Available Now

WordPress NewsMark Jaquith has just announced that WordPress 2.7 is now live and ready for download. The official announcement is now out and confirms the news.

This version of WordPress is named “Coltrane” for famed jazz Saxophonist, John Coltrane, a favorite of sax playing, WordPress founder, .

There are a lot of new features and improvements, including the new interface. For examples, screenshots, video, and information on the new WordPress 2.7 version, see WordPress 2.7 Release News and Links, Countdown to WordPress 2.7 and WordPress 2.7 Hits WordPress.com Thursday, December 4, 2008.

has been running WordPress 2.7 for a week across almost 5 million blogs and the response has been incredibly positive. Old users are finding the learning curve almost non-existent and new users are embracing it.

The hard work done by all of the development team, especially by Jane Wells who lead the conversion to the new interface, deserves some serious rounds of applause.

For those concerned about upgrading to WordPress, and how often those updates occur, take a step down memory lane with Justin Tadlock in “Be Thankful WordPress Gets Updated.” He takes you through the various versions and why we should be so thankful for the most current versions, considering the path it took to get here.

Upgrade WordPress Now!

Unlike previous versions where it’s a good idea to wait, I recommend upgrading to WordPress 2.7 now. It is very stable and has been well tested on WordPress.com. It also includes the latest security updates. Once installed, it will notify you for automatic upgrades, making the upgrade process incredibly easy.

If you are using one of the Release Candidates, the upgrade announcement should be on your blog. Follow the extended upgrade instructions. In the past, it was highly recommended that you turn off all WordPress Plugins before upgrading. WordPress 2.7 will automatically put WordPress in “maintenance mode” so this step is no longer necessary.

To upgrade from older versions of WordPress, follow the instructions in the , the online manual for WordPress Users, in Upgrading WordPress. Dependent upon which version of WordPress you are upgrading from, you may or may not have to make changes to your WordPress Theme to accommodate changes in WordPress Theme Template Tags.

If you are worried about whether or not WordPress 2.7 will work with your server, Themes or Plugins, see:

Don’t wait. It is critical that you upgrade WordPress now for the following reasons:

Upgrade to WordPress 2.7 now.



Site Search Tags: , , , , , , , , , , , ,

Feed on Lorelle on WordPress Subscribe Feedburner iconVia Feedburner Subscribe by Email Visit
Copyright Lorelle VanFossen, the author of Blogging Tips, What Bloggers Won't Tell You About Blogging.

49 Comments

  1. Alex
    Posted December 10, 2008 at 8:58 pm | Permalink

    Am I able to use the wordpress automatic upgrade plugin to upgrade to 2.7?

    • Posted December 10, 2008 at 9:23 pm | Permalink

      You can try, but make a backup first. I recommend that you do it manually, just for safety sake, so there isn’t a conflict. There have been problems with the automatic upgrade WordPress Plugin in recent versions.

  2. Posted December 10, 2008 at 9:24 pm | Permalink

    To all the people who worked on this – THANK YOU! it looks and feels amazing! – Thanks again!

  3. Posted December 10, 2008 at 9:37 pm | Permalink

    I have just released an application I wrote that uses the new WordPress 2.7 comment API. It is a freeware Mac app called WordPress Notifier. As the name suggests it alerts you when new unapproved comments some through. You get get it here:

    http://www.wpnotifier.com

  4. Posted December 10, 2008 at 9:54 pm | Permalink

    I’ve been using it since Beta 1 and can’t say anything else except: AWESOME WORK! :)

  5. Posted December 10, 2008 at 10:21 pm | Permalink

    Unlike with other versions where I have waited several weeks to a month to upgrade, I had been using the beta and release candidates on my local install on my personal computer and had the confidence in this release to go ahead and upgrade immediately and it went without a hitch, just as I expected it to. This upgrade and version is such a breath of fresh air after the 2.5 fiasco with all the problems it had. 2.7 was done right. They gave the community the chance to chime in on the interface design and communication seemed much better, especially when it came to wordpress.COM.

    This interface is what 2.5 should have been.

    • Posted December 10, 2008 at 11:25 pm | Permalink

      I agree that they should have been more aggressive with the interface improvements, but they had to go through huge levels of testing all along the way. This is a major visual change and they needed time to assess where they were and where they were going. That takes a lot of time and a lot of money invested in all types of testing. I’m eager for more details on all the various steps they tool and the lessons learned along the way – once they recover. :D

      The one thing I’ve always been impressed with when working with WordPress is the total openness, even when it hurts. They treated this upgrade the same as always, eager for community involvement and support.

  6. Posted December 10, 2008 at 11:43 pm | Permalink

    I’m frustrated! First of all when my blog stated today it wants to be upgraded to 2.6.5 i did NOT expect to upgrade to version 2.7 instead! After upgrading my Admin Drop Down Menu is gone and i have no access to anything on my blog other than posts and pages…. That Sucks!

    • Posted December 11, 2008 at 8:56 am | Permalink

      The Admin Drop Down Menu no longer works with WordPress 2.7. It has it’s own “easier” navigation. This was announced a lot over the past few months. As for the rest of your problems, I’m sure you have reported them in the WordPress Support Forum after searching to find out if anyone else is having problems. The problems will probably go away when you deactivate the Admin Drop Down Menu WordPress Plugin.

  7. Posted December 10, 2008 at 11:53 pm | Permalink

    Can’t wait to upgrade. Have been waiting since the betas

  8. mauijim
    Posted December 10, 2008 at 11:59 pm | Permalink

    Help … what happened to working with plugins? I assume there is something incredibly obvious that I’m just not seeing … but there’s nothing on my Dashboard that gives me access to plugins!

    Thanks …

    • Posted December 11, 2008 at 1:03 am | Permalink

      I don’t think I understand your question. You can still use WordPress Plugins on your blog. Access to Plugins is through the Dashboard. Did you look there? It should be there if you are using the full version of WordPress. I’m still digging into the new version.

  9. blackxxjapan
    Posted December 11, 2008 at 12:02 am | Permalink

    I’m so excited <33

    I was waiting to update my main site until it was out of the RC cycle.

  10. Posted December 11, 2008 at 1:55 am | Permalink

    I just upgraded and I liked the all new WordPress 2.7! :-D

  11. dayg
    Posted December 11, 2008 at 2:45 am | Permalink

    I just upgraded to 2.7 and can’t figure out how to create a “sticky” post.

    Thoughts?

    • Posted December 11, 2008 at 8:54 am | Permalink

      Go to the Edit Post panel and check it off as “Sticky” or “Stick to Front Page”.

  12. Posted December 11, 2008 at 5:50 am | Permalink

    That’s great news. The upgrade was a bit of a pain because a plugin autoinstaller caused a slight glitch, but it’s redundant now so I removed it.

    Other than that it’s pretty good.

  13. Posted December 11, 2008 at 6:43 am | Permalink

    I think it might be a mistake to push to have people upgrade immediately. Given that many plugins that have an admin area page might not work properly (due to the change in Plugin URL paths that now exist between 2.7 and 2.6) it will probably lead to confusion and many broken sites until Plugin authors can catch up and release new version that are 2.7 compatible. Technically inclined admins can of course compensate for problems, but many users won’t know how to deal with these issues (as at least one previous commenter seems to show). I think the best way of handling this would be to say that more technical people should upgrade immediately, others wait a few days to be sure of compatibility. This same situation happened with 2.5 and 2.6 if people remember.

    • Posted December 11, 2008 at 8:53 am | Permalink

      This version is unlike many others. The testing has been incredibly extensive, as has the preparation for Plugin and Theme authors around the world. This is the first WordPress version that I have amazing confidence in for stability and success in installation. Hang out in the Forums and see the proof for yourself. There are few major issues that aren’t related to server or browser (IE is an ongoing design battle). For those making the transition from the latest version of WordPress 2.6 to 2.7, very few complaints.

      WordPress 2.7 has totally changed my thoughts on delaying upgrading. Upgrade now, don’t wait. When fixes come in, you will be automatically upgraded. WordPress Themes are better protected from changes than ever before, and Plugins also have auto-update features. The benefits outweigh the risks dramatically.

  14. Posted December 11, 2008 at 6:44 am | Permalink

    Great release. Updated to RC1 manually and just used the auto update to get the final version…worked perfectly!

  15. Posted December 11, 2008 at 7:09 am | Permalink

    Anyone else having trouble were the WordPress News feed is not updating on the dashboard? Was working until I tried the Betas. If I go directly to the feed I see all the latest stuff but the last one in my dashboard is from Nov. 17th.

  16. Posted December 11, 2008 at 8:38 am | Permalink

    > few spam sites upgrade

    Note that the primary issue isn’t that spam sites don’t upgrade, the problem is that sites that have been compromised often have the symptoms invisible to the blog author but visible to search engine crawlers. Spammers have been systematically hacking vulnerable wordpress.org installations and putting hidden links (using CSS tricks) to their spam site. A compromised blog essentially becomes an anonymous wiki; anybody can say anything. In those cases, when there’s no way to know whether the author intended suspicious links to be there or they were placed nefariously, Technorati discontinues indexing the blog.
    -Ian
    Technorati

    • Posted December 11, 2008 at 9:09 am | Permalink

      Thank you for expanding upon this issue. There are many reasons, including risk to visitors from harmful scripts, that search engines and directories want to limit when it comes to old versions of any site, including WordPress. Many feel WordPress is being specifically targeted, but this restriction and concern applies to ALL older, less secure versions of any website generator or CMS, right? WordPress is becoming one of the most popular blogging platforms, but it isn’t alone in the concerns raised.

      Upgrading to the newest version certainly helps to eliminate the risks, so upgrade now, folks.

  17. Mena
    Posted December 11, 2008 at 9:54 am | Permalink

    Thank you for this post, I really liked the new version, the interface and every thing about it..they really did great work and effort … God Bless you all

  18. Posted December 11, 2008 at 10:35 am | Permalink

    FINALLY!!!

    Now I can do my massive backup on my PC.

  19. Posted December 11, 2008 at 11:05 am | Permalink

    I have just upgraded to WordPress 2.7 using WP automatic upgrade plugin very smoothly and nearly instantly.The interface has received a complete redesign this time.Naturally there are several enhanced features as well.Even if these are not reasons enough for opting for the upgrade,doing so primarily due to security reasons must not be overlooked.

  20. Posted December 11, 2008 at 11:59 am | Permalink

    Just for everyone’s info:

    You won’t need these types of plugins for 2.7:

    >Any Admin Drop Down Menu type plugins.

    >Reply from Admin type plugins like Ozh’ Absloute Comments.

    >Any plugins that allows you to change and/or rearrange/eliminate sections of the Dashboard.

    >Any plugin that does the same as above for the WP editor.

    The “WordPress Automatic Upgrades” plugin or any like it.

    >Any “plugin update notifier” or “plugin auto-upgrade” type plugin.

    On comment threading plugins:

    Comment threading is also included as part of 2.7 but your theme has to support this new feature so check with your theme author. Check the plugin list for 2.7 that Lorelle provided to see if your comment threading plugin is compatible.

    It’s also advisable for those who are still running an older version of “wp-config.php” (as in the one from 2.5 or for example to copy their settings over to the 2.7 version and use that instead.

    And for those still not running PHP5 it might behoove you to finally switch over.

    That’s all I can think of off the top of my head. I can attest though that Lorelle is right. 2.7 is an absolute must.

  21. Posted December 11, 2008 at 12:52 pm | Permalink

    Oh yeah…and any “sticky post” type plugins that push a given post to the top of your main page is part of the 2.7 core also.

  22. Posted December 11, 2008 at 1:17 pm | Permalink

    Any word on when/whether the Akismet Auntie Spam Greasemonkey script will be updated to work with 2.7? I know you’ve been a big champion of that.

    • Posted December 11, 2008 at 10:04 pm | Permalink

      I’m waiting to hear from Engtech from Internet Duct Tape Marketing. While the improvements to the interface are great, Akismet still needs its Auntie. :D I hope it will be soon. You are so right, I adore that Greasemonkey Script.

  23. Posted December 11, 2008 at 11:38 pm | Permalink

    I would suggest that if you are technical and can afford a bit of downtime then you can jump on the bandwagon. If you don’t much about the technicalities of WordPress or can’t afford some downtime then I would say you wait for some more time for the plugin authors to catch up and release new versions.

    • Posted December 12, 2008 at 1:42 pm | Permalink

      Actually, those will little technical experience are reporting upgrades are quick and easy – few problems. Reports in the Forums are also few during the first few days so far, compared to previous issues. I continue to highly recommend that no one wait. WordPress Plugin authors and Theme designers have had a couple months to catch up and many are. There are few breaks for Plugins and Themes beyond those listed here and in WordPress 2.7 Upgrade Tips.

  24. y8
    Posted December 12, 2008 at 12:50 am | Permalink

    WordPress 2.7 == GOOD

  25. Posted December 12, 2008 at 6:09 am | Permalink

    I do want to upgrade. Really I do. I have one critical plugin that is incompatible. I am stuck back on 2.3.3 Supposedly a rewrite is coming very soon. Lots are in this situation I presume.

    Thanks and keep up the good work

    • Posted December 12, 2008 at 1:38 pm | Permalink

      I’ve learned the hard way that there are few Plugins I can “really” live without. And that there are always better, new improved, and different Plugins that often do the same task. And if you absolutely have to have that Plugin, then pay the author or someone to keep it updated. Money for time and talent is a great encourager. :D

      Honestly, I wouldn’t wait. WordPress 2.3 is VERY vulnerable to hackers and you just told the world that your door is open for invasion. I’d find a work around really fast if I were you.

  26. Francesca
    Posted December 12, 2008 at 9:24 am | Permalink

    I upgraded to 2.7, installed a compatible theme and it all worked and works like charm.

  27. Posted December 12, 2008 at 5:28 pm | Permalink

    Unfortunately, 2.7 is still BROKEN!

    - Preview function still doesn’t work unless you publish your post to the public … which defeats the purpose of viewing your entry before anyone else gets to see those glaring mistakes.

    - If you’re signed into your account, you still can’t edit your posts while being directly at your blog site.

    - Lots of fancy crap added though! Too bad WP 2.2 made it easier to blog.

    • Posted December 13, 2008 at 12:50 am | Permalink

      I’ve been using WordPress 2.7 throughout the beta process, and the Preview function works for me, published and unpublished, when logged it. It is only meant to work with those who are logged in. I use the example.com/?p=1234 URL and it works just fine. Do it many times a day. Odd it isn’t working for you. I also have not experienced the other problem, as I edit my posts from multiple computer while at my site.

      The problem with such issues is that while you are experiencing them, they are rarely reproducible. Have you reported this on the forum and found others having the same problem? I can’t reproduce them on the many blogs I’m using WordPress 2.7 on. Tried. Sorry. Hope you figure out what is causing the problem. Could be a Plugin or something.

  28. Posted December 12, 2008 at 10:29 pm | Permalink

    WP develop so fast, I must upgrade it many times this year:(

    • Posted December 13, 2008 at 12:52 am | Permalink

      Many people think that, but honestly, my computer updates a LOT more than WordPress does. :D At least now, WordPress 2.7 has auto update which makes it very simple and easy to update. No more excuses. :D

  29. Posted December 13, 2008 at 9:23 am | Permalink

    @40
    Hi Lorelle. I noticed this behavior since upgrading to 2.6.0 and immediately reported it to forums. I have yet to hear back on that post and two other requests for help. Last month, I submitted my findings to ‘Kvetch’.

    :: sigh ::: You can imagine how frustrating it’s been not to get help while putting up with lack of WP functionality.

  30. Posted December 13, 2008 at 9:51 am | Permalink

    Does 2.7 have auto upgrade built in, without the plugin?

    • Posted December 13, 2008 at 11:22 am | Permalink

      As described in the article, automatic upgrades are built-in for future versions beyond WordPress 2.7.

      I’ve also talked to more people about using one of the auto upgrade Plugins to upgrade first, and then disable the Plugin for future versions and it works, as long as you are using the latest version and there are no other Plugins that conflict with it during the upgrade process. If you have trouble, use FTP to rename your Plugins folder and upgrade manually.

  31. Posted December 14, 2008 at 6:37 am | Permalink

    I’m normally very fast to upgrade, but complete admin design changes really make me hold off. It does seem rather intuitive… I just dislike change. Upgraded one of my blogs and everything went really smooth, I’ll probably like the new interface eventually. Maybe. Ok probably.

  32. Posted December 14, 2008 at 4:01 pm | Permalink

    I didn’t have the same luck as some of you guys on my update… I keep receiving this error message from Firefox:
    Redirect Loop
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    The browser has stopped trying to retrieve the requested item. The site is redirecting the request in a way that will never complete.

    * Have you disabled or blocked cookies required by this site?
    * NOTE: If accepting the site’s cookies does not resolve the problem, it is likely a server configuration issue and not your computer.

    however I can log into my admin page, but cannot see my blog at all.

    Tried all the suggestion from other threads as refreshing cache files from gravatars, clearing private data on tool on Firefox, desactivating all my plugins, but I just can’t see my blog at all :(
    I’m awaiting for some help from the guys on WordPress forum as it seems some other users are having the same problem.

    • Posted December 15, 2008 at 12:30 am | Permalink

      I’m glad that you addressed this issue on the WordPress Support Forum. I’m sure they will come up with an answer. Generally, these are issues that are very specific and not general. The more information you provide on the forums about your setup and server, the better they can answer you. Luckily, it sounds like others are having the same issue, so you can work as a team to resolve it.

  33. Posted December 21, 2008 at 1:58 pm | Permalink

    For some reason comments are not showing now that I have upgraded?

    • Posted December 21, 2008 at 7:48 pm | Permalink

      @Rose: If you are using a WordPress Plugin for comments, or if your Theme has been customized in the comments area, disable the Plugin, and see Enhanced Comment Display in the WordPress Codex for details.


30 Trackbacks/Pingbacks

  1. [...] WordPress 2.7 Available Now « Lorelle on WordPress [...]

  2. [...] there’s another version of WordPress out, and it looks like it’s going to be a goodie. It’s the first major release since [...]

  3. [...] bei perun.net » Info bei Lorelle » [...]

  4. [...] Lorelle on WordPress with some additional release info [...]

  5. [...] Aha. WordPress 2.7 ist fertig. Und es stellt sich als wahr heraus, was ich befürchtet habe: Das automatische Updaten, früher zuverlässig durch ein Plugin bewältigt, jetzt ein Feature der eigentlichen WordPress-Installation, zickt. Mag an den Einstellungen meines Servers liegen, oder woran auch immer. Jedenfalls: Es gibt zu tun. [...]

  6. [...] WordPress 2.7 Available Now [...]

  7. [...] Just to remind you that WordPress 2.7 is out and you can download it over here: http://lorelle.wordpress.com/2008/12/10/wordpress-27-available-now/. [...]

  8. [...] mai scris din prietenii lui Ma.tt : Lorelle , Mark si [...]

  9. [...] kullandığım WordPress yazılımını az önce 2.7 sürümüne yükselttim. Şuan detaylı kurcalama fırsatım yok ama ilk bakışta dikkatimi çeken yenilikler, [...]

  10. [...] WordPress 2.7 Available Now [...]

  11. [...] Lorelle: WordPress 2.7 Avalaible now. Etiquetas: actualizar, administración, avalaible, ayuda, bitácoras, castelno, edición, experiencia, manuales, oficial, referencias, velocidad, web, webs, wordpress [...]

  12. [...] de atualizar, dê uma lida na Lorelle e Dev Blog. Compare preços : celular, TV LCD, iPhone, Apple.Ou visite o Shopping [...]

  13. [...] Upgraded to WordPress 2.7 Upgraded, and am loving the backend. It’s just so awesome and sleek, the fresh look and [...]

  14. [...] WordPress 2.7 Available Now « Lorelle on WordPress. Written by admin in: News & Infos | Tags: WordPress [...]

  15. [...] mencoba beberapa pekan menggunakan WordPress 2.7 beta-3 akhirnya WordPress 2.7 Final tersedia juga. WordPress 2.7 mempunyai code name Coltrane seperti biasa, para developer WordPress mencintai musik [...]

  16. [...] Lorelle On WordPress: WordPress 2.7 Available Now [...]

  17. [...] over, WordPress 2.7 is finally come to us WordPress.Org users as a advanced Christmas present! Like Lorelle has mentioned, it’s pretty much recommended that all of you will upgrade to this latest and very stable [...]

  18. [...] det är den nya administrationspanelen. Läs mer om detta och många andra WordPress-nyheter på Lorelles blogg eller på WordPress utvecklingsblogg. Postades av Mattias, torsdag, december 11, 2008 16:20 [...]

  19. [...] doubt over compatibility of the plugin and theme with this new release, Lorella has posted some tips you can refer [...]

  20. [...] 2.7 is being promoted as a release, now, and so for the occasion I freshed my install from scratch. I backed up my media and database, [...]

  21. [...] WordPress 2.7 Available Now [...]

  22. [...] WordPress 2.7 Available Now (Lorelle VanFossen) [...]

  23. [...] as my favorite Lorelle from WordPress says: Don’t wait. It is critical that you upgrade WordPress now for the following [...]

  24. [...] WordPress 2.7 Available Now Mark Jaquith has just announced that WordPress 2.7 is now live and ready for download. The official announcement is now [...] [...]

  25. [...] Technology After several weeks trying to use WordPress 2.7 beta-3 finally Final WordPress 2.7 is available. WordPress 2.7 has the code name Coltrane as usual, the developer of WordPress love Jazz music. So [...]

  26. [...] WordPress 2.7 released, work is ongoing for WordPress 2.8 and WordPress wants your feedback. In [...]

  27. [...] WordPress 2.7 released, work is ongoing for WordPress 2.8 and WordPress wants your feedback. In [...]

  28. [...] mai scris din prietenii lui Ma.tt : Lorelle , Mark , Dazz [...]

  29. [...] mencoba beberapa pekan menggunakan WordPress 2.7 beta-3 akhirnya WordPress 2.7 Final tersedia juga. WordPress 2.7 mempunyai code name Coltrane seperti biasa, para developer WordPress mencintai musik [...]

  30. […] WordPress 2.7 Available Now […]

Post a Comment

Follow

Get every new post delivered to your Inbox.

Join 20,105 other followers

%d bloggers like this: