Skip navigation

WordPress Developers Still Working on PHP Compatibility

According to EWeek’s Blog Buzzword Compliant’s article “That’s Why They Call It The Bleeding Edge”, WordPress developers, like many other open and source software programmers, are battling with backwards compatibility issues as they move forward with advancements in other support software programs.

It happens all the time with proprietary software upgrades–and often, it happens on Microsoft’s “Patch Tuesday.” You get the latest update, and load it up (hopefully in a test environment) only to find that it breaks something else–like that legacy application with some dependency that just got destroyed by the upgrade.

But it’s an increasing problem in the open-source realm as well. As projects reach major forks in the road (and the code) in an attempt to add new features or close potential security issues, other projects that have depended on common development practices that worked on previous versions either have to rush to fix broken code or force their user base to stick with older (and potentially vulnerable) infrastructure elements.

Take, for example, the great weblogging software, WordPress. Take the current, and try to install it on a machine with a default installation of the latest version of MySQL — version 5.0.1– and with PHP 5. Just try.

I did. It wasn’t pretty. I ended up having to create a new instance of MySQL that ditched the “strict” SQL mode that 5.0 runs in by default.

Both MySQL 5 and PHP 5 have major functionality additions that required a break with backward compatibility. This is something the WordPress committers are working on for their 2.0 release, which is in beta.

The current WordPress release breaks to some degree because of efforts to make WordPress backward-compatible with previous versions of PHP.

This is not a major bug or crisis for WordPress users, it’s just the way of the world. I can’t tell you how many times over the past 20 plus years I’ve installed a new version of something, be it major corporate monopolyware, shareware, or freeware, and it didn’t quite “play well with others”. Programming for backwards and forwards compatibility adds bulk to programming code and makes life miserable for both the developers and the users. Somethings got to give and a compromise must be found, and unfortunately, it isn’t always the users who benefit, nor is it the developers.

So that you understand, as of right now, MySQL 5 and PHP 5 don’t play well with WordPress. The issues are being examined and plans made. For now, just like any other software program, read the Hosting WordPress – Installation Requirements to understand what is necessary in order for WordPress to run properly. You may or may not have control over these requirements as they are available from your server host, but if you are also looking for a new host, then these are the requirements you need to ensure they have in order to make your life with WordPress move smoothly. For now. Stay tuned for updates. ;-)


Site Search Tags: , , , , , , , , , , ,
Copyright Lorelle VanFossen

Post a Comment

Follow

Get every new post delivered to your Inbox.

Join 20,573 other followers

%d bloggers like this: